Skip to content

SIP协议 ​


RFC ​

RFC 2733 - An RTP Payload Format for Generic Forward Error Correction
RFC 3261 - SIP: Session Initiation Protocol
RFC 3264 - An Offer/Answer Model with Session Description Protocol (SDP)
RFC 3407 - SDP Simple Capability Negotiation
RFC 3550 - RTP: A Transport Protocol for Real-Time Applications
RFC 3551 - RTP Profile for Audio and Video Conferences with Minimal Control
RFC 3711 - The Secure Real-time Transport Protocol (SRTP)
RFC 3830 - MIKEY: Multimedia Internet KEYing
RFC 4566 - SDP: Session Description Protocol
RFC 4567 - Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP)
RFC 4568 - Session Description Protocol (SDP)Security Descriptions for Media Streams
RFC 4585 - Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)
RFC 4771 - Integrity Transform Carrying Roll-Over Counter for the Secure Real-time Transport Protocol (SRTP)
RFC 4474 - Enhancements for Authenticated Identity Management in the Session Initiation Protocol (SIP)
RFC 4916 - Connected Identity in the Session Initiation Protocol (SIP)
RFC 4585 - Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)
RFC 4771 - Integrity Transform Carrying Roll-Over Counter for the Secure Real-time Transport Protocol (SRTP)
RFC 4568 - Session Description Protocol (SDP) Security Descriptions for Media Streams
RFC 4916 - Connected Identity in the Session Initiation Protocol (SIP)
RFC 5124 - Extended Secure RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/SAVPF)
RFC 5506 - Support for Reduced-Size RTCP, Opportunities and Consequences
RFC 5669 - The SEED Cipher Algorithm and Its Use with the Secure Real-time Transport Protocol (SRTP)
RFC 5763 - Framework for Establishing an SRTP Security Context using DTLS
RFC 5764 - Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)
RFC 6188 - The use of AES-192 and AES-256 in Secure RTP
RFC 6189 - ZRTP: Media Path Key Agreement for Unicast Secure RTP
RFC 6904 - Encryption of Header Extensions in the Secure Real-time Transport Protocol (SRTP)
RFC 7714 - AES-GCM Authenticated Encryption in the Secure Real-time Transport Protocol (SRTP)

其他 ​

RFC3550中文版
RTP-Wikipedia
SRTP-Wikipedia
Securing Internet Telephony Media with SRTP and SDP - Cisco

SIP - voip-info.org
SBC排名
微软认证SBC
Asterisk学习中心
opus

Oracle Communications Tunneled Session Controller
Oracle SBC配置指导

Comparison of VoIP software

应用 ​

SBC典型应用拓扑图

SIP服务器 ​

kamailio
asterisk
FreeSWITCH
opensips

SIP测试工具 ​

StarTrinity software

参数 ​

Session Description Protocol (SDP) Parameters
Datagram Transport Layer Security (DTLS) Extension to Establish Keys for Secure Real-time Transport Protocol (SRTP)
Session Description Protocol (SDP) Security Descriptions